Gunner Forum banner

1 - 13 of 13 Posts

·
Site Founder
Joined
·
25,453 Posts
Discussion Starter #1
My turret press is screwed up. In order for it to move on the down stroke there's a little square plastic piece that goes around the twisted shaft. That little plastic piece basically stripped and doesn't rotate the press anymore. I've only loaded about 1000 rounds on it. Anyone else have this problem? I'm thinking I can replace the plastic piece with an aluminum one. I just have to figure out how to make one.
 

·
Registered
Joined
·
6,150 Posts
i've worn bushings out before, i bet if ya contact lee and explain they will probably send ya a free one or two of them.....

ya can always remove the shaft and hand rotate if ya need to..........
 

·
Site Founder
Joined
·
25,453 Posts
Discussion Starter #3
That's what I'm doing now. I forget to rotate it once in a while and have to use the old bullet puller. :shock:
 

·
Registered
Joined
·
6,148 Posts
I replaced the screw and added a nut, the nut was not me. :lol:
 

·
Site Founder
Joined
·
25,453 Posts
Discussion Starter #5
How do you mean? I could replace the plastic bushing with a metal bushing I think. I'm not sure if it would damage the shaft or not though.
 

·
Registered
Joined
·
6,148 Posts
On my Lee press the screw that puts tension on the shaft would not tighten up, replaced with a longer screw and nilock nut.
 

·
Site Founder
Joined
·
25,453 Posts
Discussion Starter #7
XLCH said:
On my Lee press the screw that puts tension on the shaft would not tighten up, replaced with a longer screw and nilock nut.
Yeah mine was in need of tightening often too. I dropped the stupid bushing under the press and can't get at it unless I unbolt it. :roll: I guess I should go after it and see if I can do what you did and get it to work again.
 

·
Registered
Joined
·
6,148 Posts
It worked good for me, you need to pay attention to how tight you make it
 

·
Registered
Joined
·
4,139 Posts
BH, call Lee. They will send you a new one. Then, you can buy a couple more for $.50 each. I believe the part # is TF3567.

BTW: make sure when you install the new square ratchet, that the auto-index clamp grabs the lip in the slot, correctly.....don't even ask how I know..... :eek:
 

·
Site Founder
Joined
·
25,453 Posts
Discussion Starter #12
I just looked at it and I think the rachet was in wrong. I'm such a pain in my ass. :|
 

·
Registered
Joined
·
4,139 Posts
Yea, it definately will not work if it's in upside-down, or if it doesn't sit in that groove....that's what happened to mine, after I removed the auto index clamp....didn't take long to realize, "Houston, we have a problem. I now have 2 spare clamps and 2 spare ratchets.....
 
1 - 13 of 13 Posts
Top