Gunner Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
4,131 Posts
Discussion Starter · #1 ·
My BIL and I got to shoot some, before the match was rained out. He shot some of my reloads through his Taurus PT111. He had three rounds in a row that failed to fire. He set the rounds aside, and later we checked them.....all three had solid primer strikes....the primers were just dead. At first, I thought they might be light strikes, but no...the strikes were solid. Has anyone ever experienced this with Win primers?
 

· Registered
Joined
·
4,131 Posts
Discussion Starter · #3 ·
I shot some with Win primers too, and compared those three what I shot through my Sig....primer strikes were pretty much the same....guess I should have tried those three through my gun.....
 

· Registered
Joined
·
4,131 Posts
Discussion Starter · #11 ·
I should have tried them in another gun....If it happens again, I will......

BTW: if it makes any difference, and it doesn't, I guess, I've always used Federal primers with no problems.....
 

· Registered
Joined
·
4,131 Posts
Discussion Starter · #16 ·
I didn't contact Winchester, but a couple of weeks ago, at a practice match, I had 2 more dead primers out of 120 rds. Tried to fire each 3 times out of my GP100, and another guy tried to fire the twice out of his S&W.....disassembled them the next day, and all I can say is they are just dead. So, now I have 9mm and .38specials that may or may not fire, because of the primers. I only have 200 more, and then I start using the CCI's....hope they work better, because the cost of Federals has gone through the roof.....
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top